icon-rss-large

中文泛技术类IT博客 | 留言

软路由 | 硬路由 | 网站地图 |

DDNS动态域名脚本(花生壳+3322公云)for ROS 6.x(转)

发表于 2016年08月28日 软路由版

一、花生壳
花生壳动态域名是全球用户量最大的完全免费的动态域名解析软件(DDNS)。当您安装并注册花生壳动态域名解析软件,无论您在任何地点、任何时间、使用任 何线路,均可利用这一服务建立拥有固定域名和最大自主权的互联网主机。“花生壳动态域名解析软件”支持的线路包括普通电话线、ISDN、ADSL、有线电 视网络、双绞线到户的宽带网和其它任何能够提供互联网真实IP的接入服务线路,而无论连接获得的IP属于动态还是静态。
现在花生壳动态域名解析软件为千万的域名提供动态域名解析服务,并广泛应用于网站建设、视频监控、遥感测绘、FTP、VPN、企业OA、ERP等应用领域。

脚本:

local ipaddr
local server “http://ddns.oray.com
local domain “域名”
local par “/ph/update?&hostname=$domain&myip=$ipaddr”
local users “用户”
local paswd “密码”
:set ipaddr [/ip address get [/ip address find interface=pppoe-out2] address]
:set ipaddr [:pick $ipaddr 0 ([len $ipaddr] -3)]
/tool fetch url=($server . $par) mode=http user=$users password=$paswd



二、3322

脚本:


:local ednsuser “用户”
:local ednspass “密码”
:local ednshost “域名”
:local ednsinterface “接口”
:local members “http://members.3322.org/dyndns/update?system=dyndns
#:local members “http://members./nic/update?”
:local status
:local status [/interface get [/interface find name=$ednsinterface] running]
:if ($status!=false) do={
:local ednslastip [:resolve $ednshost]
:if ([ :typeof $ednslastip ] = nil ) do={ :local ednslastip “0” }
:local ednsiph [ /ip address get [/ip address find interface=$ednsinterface ] address ]
:local ednsip [:pick $ednsiph 0 [:find $ednsiph “/”]]
:local ednsstr “&hostname=$ednshost&myip=$ednsip”
:if ($ednslastip != $ednsip) do={/tool fetch url=($members . $ednsstr) mode=http user=$ednsuser password=$ednspass dst-path=$ednshost
:delay 2
:local result [/file get $ednshost contents]
:log info ($ednshost . ” ” .$result)
/file remove $ednshost ;
}
}


本文标题:DDNS动态域名脚本(花生壳+3322公云)for ROS 6.x(转)
本文链接:http://www.china-snail.com/index.php/post/920.html
作者授权:除特别说明外,本文由 citywo 原创编译并授权 大城小我 刊载发布。
版权声明:本文不使用任何协议授权,您可以任何形式自由转载或使用。
0
留言区
留言区

腾讯分分彩 www.273956.cc-香港时时彩是官方吗| www.1121.me-竞彩半全场中奖| www.9756.cm-彩八仙ios-| www.570982.com-中国体彩育彩票开奖| www.567706.com-七彩本草安神方价格| www.850914.com-时时彩怎么个玩法| www.11wi.com-中国体育彩票十| www.0198.org-国家统一开奖的彩票| www.7781.cm-七乐彩及中奖规则| www.8360.in-海南七星彩下载软件| www.44021.com-凤凰彩票时时彩计划| www.151720.com-中体彩网官网| www.402766.com-新浪爱彩买不起了| www.539618.com-釉下彩餐具制作| www.636673.com-礼拜六开什么彩票| www.712216.com-彩票坊是不是黑网站| www.799975.com-福彩双色球直播现场| www.876937.com-怎么买体彩-| www.966006.com-全民快三代理| www.cz49.com-幸运5快三-| www.wk22.com-中彩在线手机版| www.74tv.com-七星彩19017期| www.3303.com-华宇彩票平台骗局| www.9300.top-新加坡49彩票开奖| www.cp435.com-极速快三app下载| www.210689.com-快三代理好做吗| www.289685.com-826cc彩票-| www.365691.cc-最近体彩开奖号码| www.254572.com-网络彩票提款被拒| www.343955.com-体彩即时彩规则| www.397266.com-体育彩票七星彩选号| www.968567.com-1分彩怎么才能赚钱| www.795364.com-彩票100本回血| www.50765.com-888彩票网络| www.022319.com-重庆时彩时彩图| www.112002.com-中彩票1亿-| www.96896.com-体彩福彩合并申请书| www.073992.com-玩足彩用什么app| www.978768.com-彩坛公式规律专区| 500彩票www.379477.com| www.u31.club-速盈彩是什么| www.267053.com-彩票开奖直播频道| www.793689.com-开私彩犯罪吗| www.41mf.com-手机怎么打七星彩| www.93728.com-足彩推荐平台哪个好| www.107801.com-彩票软件破解| www.228866.com-江苏彩票11选5| www.308630.com-安徽彩票快3| www.891646.com-体育彩票术语大全| 杏彩www.00840z.com| www.9959.pw-体彩利润多少个点| www.607349.com-外国彩票中奖号| www.637692.com-彩票发展趋势| www.751273.com-彩票条形码撕坏| www.819318.com-彩票高手个人推荐| www.980427.com-广西体彩电话投注| www.aj97.com-手机购买双色球彩票| www.qp95.com-彩票有什么-| www.12.org-大马彩在哪查开奖| www.55803.com-怎样买快三-| www.729435.com-双色球新浪爰彩| www.875906.com-宝马彩票官方网站| www.mf6.com-河北快三预测一定牛| www.08pv.com-尼彩手机是智能机吗| www.82853.cc-新浪竞彩官网| www.cai09.com-10分快三-| www.196365.cc-时时彩游戏机| www.277293.com-网彩可靠吗-| www.17637.cc-足球彩票让球投注| www.77318.cc-彩经网印尼5分彩| www.050847.com-买福彩快三如何赚钱| www.160153.com-玩快开彩票输了| www.081257.com-中彩票视频-| www.172112.com-查江苏快三开奖结果| www.138897.com-吉林快三怎么打胆拖| www.219428.com-福建福彩15-| www.620487.com-vr三分彩走势图| www.719595.com-彩票的税2019| www.45pv.com-盛大娱乐彩票合法吗| www.1221.in-全民双色球彩票官网| www.7268.top-彩虹六号妖怪冲击波| www.23848.com-颖彩双色球独蓝预测| www.65233.cc-福彩谜语走势图| www.913523.com-彩客网ios客户端| www.980879.com-金彩网马会中特彩票| www.ce30.com-快三亏-| www.uu25.cc-合法体彩外围网站| www.6683.vip-乐视赢家彩票| www.324838.com-彩票统计器-| www.397974.com-彩票合质是什么意思| www.nc4.com-江苏快三中奖玩法| www.1nj.com-l乐彩写真机| www.89iq.com-京彩7515网页| www.882707.com-河南彩礼排行榜| www.690048.com-福彩3d徐老师预测| www.838161.com-贵阳彩票店转让| www.971002.com-福彩多少种玩法| www.ox22.com-福降天下牛彩| www.5218.cn-巴西三分彩开奖查询| www.39895.com-赛车彩票首页| www.293852.com-快三长龙助手免费版| www.3608.cc-南方彩票双彩网下载| www.528300.com-时时彩买什么挂什么| www.45ug.com-七星彩打奖规律表| www.471888.cc-香港官网彩票| www.012656.com-廉江好彩哥交流论坛| www.123193.com-欢乐彩快3-| 彩客网www.138037.com| www.18qf.com-彩票大王杨光华书籍| www.71216.com-选彩-| www.21jg.com-福彩app刷彩单| www.188296.com-内蒙福彩三的| www.926651.com-五福彩票官方网站| www.cp6113.com-福利彩票app下载| www.555669.cc-顶尖彩票诈骗| www.665857.com-七星彩中奖省份查询| www.752329.com-中彩吧平台-| www.100350.com-乐彩客app苹果| www.162566.com-大運彩票-| www.165369.com-创富彩票是什么| www.519208.com-赢彩票软件-| www.588424.com-彩网大赢家-| www.658749.com-范伟买彩票中奖号码| www.722075.com-彩票福3d怎么玩| www.154505.com-qq分分彩玩法说明| www.243069.com-新3d彩票计划骗局| www.72226.com-彩票充值送彩金平台| www.013415.com-湖北快三助手下载| www.072415.com-乐亿彩票平台app| www.02369.com-2mcc彩票下截| www.978400.com-彩色透水混凝土配料| www.fl04.com-黑彩靠什么盈利| www.yl60.cc-易彩快3中奖规则| www.46vi.com-竞彩标准店图片| www.881.net-快三彩票止损方法| www.5618.in-被重庆时时彩票骗局| www.713278.com-美国16亿彩票| www.791845.com-福彩数字三开奖号码| www.859789.com-彩9彩票下载安装| www.96ux.com-福利彩票兑奖查询| www.757337.com-体彩店刷佣金违规吗| www.874342.com-快三有人控制| www.958430.com-七星彩2字现多少倍| www.997966.cc-苹果彩票导航| www.dd09.com-cp彩票-| www.tn21.com-快三北京快三开奖号| www.021822.com-微信足彩群-| www.257920.com-038彩票上瘾了| www.318252.com-十字彩赌博怎么玩的| www.122115.com-希腊时时彩软件| www.74qh.com-万豪彩票真假| www.926503.com-瑞彩祥云结不了卡| www.nx71.com-十分彩快三-| www.19uf.com-第一次怎么买彩票| www.358918.com-四川福彩手机报下载| www.598863.com-福彩3d资讯-| www.707234.com-福建体彩11一定牛| www.793190.com-彩票九是不是假的| www.878522.com-网赌彩票倍投骗局| 名门彩www.33997q.com| www.661245.com-好用的彩票计划| www.972581.com-普通彩铅画星空简单| www.0826.org-网易彩票旧版首页| www.hp28.com-彩票号码生成器|